
 

  

SNIPPET EDITOR  
SETUP & INSTRUCTIONS 

PV 620  SV 100 

 



Contents 

Overview ...................................................................................................................... 2 

Setup & Installation ................................................................................................... 3 

Dependencies............................................................................................................................................ 3 

Select the Snippet Editor Development Location ..................................................................................... 3 

Create the OneStream XF Development Application ............................................................................... 4 

Application Server Settings ....................................................................................................................... 4 

Configure the OneStream XF Application Server .................................................................................. 4 

Install Snippet Editor ................................................................................................................................. 5 

Set Up Snippet Editor ................................................................................................................................ 5 

Create Tables and Launch Solution ....................................................................................................... 6 

Package Contents .................................................................................................................................. 6 

Settings ......................................................................................................................... 7 

Global Options .......................................................................................................................................... 7 

Default Author ...................................................................................................................................... 7 

Categories ................................................................................................................................................. 7 

Categories and SubCategories Button Bar ............................................................................................ 8 

Create Categories and SubCategories ................................................................................................... 9 

Uninstall .................................................................................................................................................... 9 

Editor ........................................................................................................................... 10 

Snippet Editor Filters ........................................................................................................................... 10 

Snippet Editor Buttons ........................................................................................................................ 11 

Import Snippet Data ................................................................................................................................ 11 

Download Template ................................................................................................................................ 12 

Pivot  .................................................................................................................................................... 12 

Help & Miscellaneous Information ...................................................................... 13 

Display Settings ....................................................................................................................................... 13 

Package Contents & Naming Conventions.............................................................................................. 13 

Solution Database Migration Advice ...................................................................................................... 14 

MarketPlace Solution Modification Considerations ............................................................................... 14 

 



 

Page 2 of 15 

OVERVIEW 
The Snippet Editor solution lets you create and edit sample OneStream XF snippets. Snippets provide 
pre-tested code samples, making it easier to write high quality scripts in OneStream XF in a shorter 
amount of time. 

Hundreds of sample snippets are included and ready to be imported into any OneStream XF server 
instance. There are several categories of snippet samples, including: 

• Formulas 
• Calculations 
• Lists 
• Data flows 
• Rules 
• Helpers 
• Mappings 
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SETUP & INSTALLATION 
This section contains important details related to the planning, configuring, and installation of your 
solution. Before you install Snippet Editor, familiarize yourself with these details.  

See also: MarketPlace Solution Modification Considerations 

Dependencies 
Component Description 
OneStream XF 6.2.0 or later Minimum OneStream Platform version required to install this 

version of Snippet Editor. 
 

Experience is required to write VB.NET code snippets in OneStream XF and in the Snippet Editor. Refer 
to Microsoft VB.NET reference documentation for more information on writing snippets. 

Select the Snippet Editor Development Location  
Before beginning installation, decide whether to build Snippet Editor directly in the Production 
OneStream XF application or in a separate Development OneStream XF application. This section 
provides some key considerations for each option.  

You also need consider if the Development or Production environments share the same OneStream 
Framework. Snippets are stored on the OneStream Framework database. If you are using the same 
OneStream Framework in the Development and Production environments, you do not need to migrate. 
Additionally, only the snippets themselves would need to be migrated. These are migrated by extracting 
the snippets from the System tab, then loading them back into OneStream XF after a database 
migration. 

See also: Solution Database Migration Advice 

Production OneStream XF Application: The primary advantage of building Snippet Editor in a 
Production application is that you do not have to migrate the resulting work from a Development 
application. However, there are intrinsic risks when making design changes to an application used in a 
Production capacity and not advised. 

 

Note: OneStream recommends that you implement Snippet Editor in the Development 
environment with a fresh copy of the Production application before starting work. 

 

Development OneStream XF Application: As a best practice, use the Development OneStream XF 
application to build Snippet Editor. 
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Create the OneStream XF Development Application 
1. Ensure all OneStream XF artifacts relating to Snippet Editor are in the Production application. 
2. Copy your Production OneStream XF application to your Development environment and rename 

it. This Development version is used for your Snippet Editor project.  

Application Server Settings 
You may need to edit the OneStream XF Application Server Configuration so users can create and 
change data in the additional database tables used by Snippet Editor. If other MarketPlace Solutions 
(such as Specialty Planning) are already in the application, these adjustments may already exist. 

See also: Solution Database Migration Advice 

Configure the OneStream XF Application Server 
Be sure that the security group settings include the users who will be working on and setting up Snippet 
Editor before proceeding.  

 

Note: Group settings are applicable to all XF MarketPlace solutions; it is important to keep 
the group names generic. 

1. Start the OneStream XF Server Configuration Utility as an Administrator.  
2. Select Open Application Server Configuration File > Database 
3. Edit the following OneStream Database Server properties: 

• Access Group for Ancillary Tables: Select a group that includes those who access records. 
• Can Create Ancillary Tables: True 
• Can Edit Ancillary Table Data: True 
• Maintenance Group for Ancillary Tables: Select a group who will edit and maintain tables. 
• Table Creation Group for Ancillary Tables: Select a group who can create tables.  

 

4. Restart Internet Information Server.  
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Install Snippet Editor 
1. On the OneStream XF MarketPlace Dashboard, click MarketPlace > Snippet Editor. 

 

2. On the Snippet Editor Solution page, select the appropriate OneStream XF platform version from 
the Minimum Platform Version drop-down list.  

3. Select the most recent version from the Solution Version drop-down list and then click 
Download. 

4. Log in to OneStream XF. 
5. On the Application tab, click Tools > Load/Extract.  
6. On the Load tab, locate the solution package using the Select File icons and click Open. 
7. When the solution’s file name appears, click Load.  
8. Click Close to complete the installation.  

Set Up Snippet Editor 
The first time you run Snippet Editor, you are guided through the table setup process. 

• In OneStream XF, click OnePlace > Dashboards > Snippet Editor > Snippet Editor. 

 

  



 

Page 6 of 15 

Create Tables and Launch Solution 
1. Click Step 1: Create Tables 

This step may be necessary when upgrading even if tables already exist. Snippet Editor does not 
drop existing tables but modifies table structures and will add new ones if necessary. 

 

2. When setup is complete, click Step 2: Launch Solution to open Snippet Editor. 

Package Contents 
The Dashboard Maintenance Unit provides the user interface for Snippet Editor and includes the 
required Dashboard Groups, Components, Data Adapters, Parameters, and files. 

Business Rules: The following Business Rules are included: 

SNE_HelperQueries 
Dashboard dataset Business Rule that can look up lists of snippets and snippet categories. 

SNE_SolutionHelper 
Dashboard extender Business Rule that allows for the addition, maintenance and navigation of snippets 
on the main dashboard. 

SNE_ParamHelper 
Dashboard XFBR string Business Rule provides conditional parameter processing functions that allow a 
parameter value to be interpreted and substituted with a different string. 
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SETTINGS 

 
The Settings page contains the Global Options tab in which key properties that guide 
administration are set as well as Categories and Uninstall options.  

Global Options 
The Global Options page should be the first page accessed during the initial setup and configuration of 
Snippet Editor. 

 

Note: All global option settings are retained during solution upgrades. 

 

 

Default Author 
The Default Author is automatically assigned to a new snippet. This freeform text field displays in the 
Author field of Snippet Editor grids. 

 

Note: You can change an individual snippet author’s name on the Editor page. 

 

Categories  
Organize your snippets by creating categories and sub-categories. Categories and sub-categories align 
your snippets into logical groups for the current module type and let you customize their display in 
Snippet Editor.  
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The Module Type drop down contains a list of predefined snippet modules. Each module type is only 
available in specific areas of OneStream XF. Module types include: 

• General 
• Finance 
• Stage 
• CubeView 
• Dashboard 
• Extender 
• Event Handler 

The following grid shows each module’s availability in the Business Rules and other areas of OneStream 
XF. 

 

Categories and SubCategories Button Bar 
Use buttons in the Categories and SubCategories panes to add, delete, and save category and sub-
category entries. All created categories and sub-categories appear in the Category and SubCategory 
drop-downs on the Editor page, which lets you filter the list of snippets on that page. 

 

See also: Snippet Editor Page 

Insert Row - Add a new category or sub-category. 
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Delete Row(s) - Select a category or sub-category in the Category or SubCategory pane, then click 
Delete in that pane to delete the item. 

Cancel  - removes changes made to categories and sub-categories since the last save. 

Save - Saves updated task groups. 

Create Categories and SubCategories 
The Categories page includes a Categories pane and a SubCategories pane, where you can build out the 
category and sub-category relationships for the current module type:  

1. In the Module Type drop-down, select the module type for which you want to create categories 
and sub-categories. 

2. Click the Add button in the Categories pane to create a new row, then click the Category column 
in the new row to edit its contents. 

3. Enter the name of the category you want to add and click Save. 
4. Click Add in the SubCategories pane to create a new sub-category row, then click the 

SubCategory column in the new row to edit its contents. 
5.  Enter the name of the sub-category you want to add and click Save. 
6.  Repeat steps 2 through 5 to add additional categories and sub-categories. 

Uninstall 
The Uninstall feature allows the Snippet Editor User Interface or the entire solution to be uninstalled.  

Note that if part of an upgrade, any modifications performed on standard Snippet Editor objects will be 
removed. There are two Uninstall options:  

1. Uninstall UI removes Snippet Editor, including related dashboards and Rules but leaves the 
database and related tables in place. For some releases, this step should be performed before 
accepting any new version of Snippet Editor since some of the Dashboards or other objects may 
have been modified. 

• Choose this option if you want to accept a Snippet Editor update without removing the 
data tables. 

• The Snippet Editor  Release Notes will indicate if an overinstall is supported. 
2. Uninstall Full removes all the related data tables, all data, Snippet Editor Dashboards, and 

Business Rules.  
• Choose this option to completely remove Snippet Editor or to perform an upgrade that 

is so significant in its changes to the data tables that this method is required. 
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EDITOR  

 

Once you create categories and sub-categories, use the Editor page to create and edit 
snippets. You also use this page to download a Microsoft Excel template and create snippet 
information to import back into the Snippet Editor. 

 

 

Select the grouping (Module|Category|SubCategory) using the drop down lists. Once selected, click 
Refresh to display the snippets for the selected grouping. You can also add additional snippets directly in 
the snippet grid, or edit existing snippets. 

Snippet Editor Filters 
Snippet Editor filters display on the Snippet Editor page. Use the drop-down lists to apply filters to see 
only specific snippets.  

 

Module Type - These are the pre-defined module types in the system that categories and sub-categories 
are based. Select one of the module types from the list to display snippets created for that type. Module 
types are defined when Business Rules are created in OneStream XF.  

See also: Categories 
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Category - These are the categories for the selected module using the Categories page of the Snippet 
Editor settings. Use the list to select the category for which you want to view and create snippets.  

See also: Categories 

SubCategory - These are the sub-categories you created for the selected module and category using the 
Categories page of the Snippet Editor settings. Use the list to select the sub-category within the 
selected category for which you want to view and edit snippets.  

See also: Categories 

Snippet Editor Buttons 

Refresh - Refreshes the grid that displays snippet data. Click Refresh after selecting display criteria in the 
Module Type, Category, and SubCategory dropdowns to display snippet content matching the selection 
criteria. 

Import – Allows you to navigate to and select a Microsoft Excel file containing snippet data you want to 
import into OneStream XF Snippet Editor.  

See also: Import Snippet Data 

Download – Allows you to download a Microsoft Excel template you can use to create or load snippet 
data from an external source.  

See also: Download Template 

Import Snippet Data 
OneStream provides a Microsoft Excel template you can use to create snippet data or load it from an 
external source, then import data back into OneStream. In the template on the Snippet Template tab, 
enter updates to or add new snippet data in the ranges between the blue lines. Insert additional rows 
within this range to allow for more snippet data. 

The Module Type field in the template lets you select a predefined module type . When loading snippet 
data, each snippet’s module type must match the module types in the list, otherwise an error occurs 
during import. 

To manually enter snippet data in the template, start by selecting a valid module type from the 
dropdown. Then you can enter data in the rest of the fields to complete a snippet data record. 
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After entering data in the template, save it and close the file before importing. 

Download Template 
OneStream provides a Microsoft Excel template you can use to define your snippets. Once defined, you 
can import the snippet data into OneStream XF, where you can view and further edit them in the 
Snippet Editor. Use the Snippet Template tab in the template to enter updates to or add new snippet 
entries in the ranges between the blue lines. Insert additional rows within this range to allow for more 
snippet data. 

After entering data in the template, save it and close the file before importing. 

Pivot 

 
The Pivot page displays all snippets in a grid and has drag and drop capabilities which allow 
users to pivot on any field in the grid. 

Use the Pivot page to see only the specific existing snippets you want to focus on. Drag a column to the 
blue row at the top of the grid to pivot on that field.  

 



 

Page 13 of 15 

HELP & MISCELLANEOUS INFORMATION 

 
This page contains solution documentation for the Snippet Editor.  

Display Settings 
OneStream XF and XF MarketPlace solutions frequently require the display of multiple data elements for 
proper data entry and analysis. Therefore, the recommended screen resolution is a minimum of 1920 x 
1080 for optimal rendering of forms and reports. 

Additionally, OneStream recommends that you adjust the Windows System Display text setting to 100% 
and do not apply any Custom Scaling options. 

Package Contents & Naming Conventions 
The package file name contains multiple identifiers that correspond with the Platform. Renaming any of 
the elements contained in a Package is discouraged in order to preserve the integrity of the naming 
conventions. 

Example Package Name: SNE_PV6.2.0_SV100_PackageContents.zip 

Identifier Description 
SNE Solution ID 
PV6.2.0 Minimum XF Platform version required to run solution 
SV100 Solution version 
PackageContents File name 
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Solution Database Migration Advice 
All updates made in Snippet Editor are stored in the BRSnippet table in the framework. The data for the 

BRSnippet table can be extracted to an XML file, then loaded back into OneStream XF after 
migrating the database.  

1. In OneStream XF, click System > Tools > Load/Extract. 
2. Click the Extract tab, then select Snippets from the File Type drop-down. Snippet items to 

extract appear in the Items to Extract tree view. All snippets are selected for extraction by 
default. 

3. Click Extract, then use the Windows Save As dialog box to navigate to and select the location to 
store the extract XML file.  

4. Click OK. 

Once the framework database is migrated, you can load the XML file back into OneStream XL. 

1. In OneStream XF, click System > Tools > Load/Extract. 
2. Click the Load tab, then click the ellipsis button in the File Name field.  
3. Use the Windows Open dialog box to navigate to and select the location where you stored the 

extracted XML file.  
4. Click Open, then click Load to load the snippet data back into OneStream XF. 

A progress bar indicates when the load completes. 

MarketPlace Solution Modification Considerations 
A few cautions and considerations regarding modification of MarketPlace Solutions:  

• Major changes to Business Rules or custom tables within a MarketPlace Solution will not be 
supported through normal channels as the resulting solution is significantly different from the 
core solution.  

• If changes are made to any Dashboard object or Business Rule, consider renaming it or copying 
it to a new object first. This is important because if there is an upgrade to the MarketPlace 
Solution in the future and the customer applies the upgrade, this will overlay and wipe out the 
changes. This also applies when updating any of the standard reports and Dashboards.  

• If modifications are made to a MarketPlace Solution, upgrading to later versions will be more 
complex depending on the degree of customization. Simple changes such as changing a logo or 
colors on a Dashboard do not impact upgrades significantly. Making changes to the custom 
database tables and Business Rules, which should be avoided, will make an upgrade even more 
complicated. 
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